If you follow the tech news, you probably know that the latest version of Mac OS is out… it’s called Catalina. If you’re like me, you want to install and run the latest OS right away. I’m holding off on Catalina right now and you probably should too.

Why?

Well, Catalina is incompatible with 32-bit apps. They won’t run at all. These are primarily older apps, but some that are still in use, especially in education. For example, I won’t be updating my Northern Buckeye MacBook just yet because the LEGO Mindstorms EV3 software is 32-bit.

But how do you know which apps are 32 bit? 

 

Click on About This Mac under the Apple menu. In the window, click on System Report

In that window, under Software, click on Applications. Now wait.

On the far right column (you may need to stretch your window a bit to see it), click on 64 bit, which will group all the apps by either 64 bit or 32 bit. If the 64-bit column says no, then the app will not run at all in Catalina.

As you can see, this particular Mac has quite a few apps that aren’t 32 bit. When I ran this on my work Mac, there were only 5 incompatible apps. But one of them is the EV3 software, which is a deal-breaker.

If you have incompatible apps, check the developer’s website to see if there is an update available or planned. For many of the older apps, you may be out of luck. 

If your Mac has Boot Camp with a working version of Windows, you might be able to run the Windows version instead.

Ultimately, you need to decide for yourself whether or not this upgrade is a good idea. For me, right now the answer is No!

 

Chris Malanga on EmailChris Malanga on FacebookChris Malanga on LinkedinChris Malanga on Twitter
Chris Malanga
Educational Technologist @ Northern Buckeye
Google Certified Trainer
LEGO® Education Certified Trainer